Error 1083 “The executable program that this service is configured to run in does not implement the service”

When you attempt to start some Windows services using the Services MMC or command-line, error 1083 or 1053 is shown, and the service fails to start. Here is the error message verbatim:

Windows could not start the [service name] service on Local Computer.Error 1083: The executable program that this service is configured to run in does not implement the service

This article tells you how to fix the error 1083 and 1053 when turning on a Windows service which is hosted by svchost.exe.

Fix Error 1083 “The executable program that this service is configured to run in does not implement the service”

To fix Services error 1083 and 1053 in any version of Windows, follow these steps:



  1. Open the Services console by running services.msc from Run dialog.
  2. Double-click the service that you want to start (but unable to).
  3. In the General tab of the service properties, note down the following:
    • The short name of the service
    • Service host group name
      fix for services error 1083 and 1053
  4. Start the Registry Editor (regedit.exe) and go to the following branch:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Svchost
  5. In the right-pane, double-click the service host group registry value. In this case, we’ve found the host group to be LocalServiceAndNoImpersonation for the Smart Card service.
  6. Add the service’s short name (in this case, its SCardSvr) anywhere in the multi-string value. Refer to the following image.
    fix for services error 1083 and 1053 - windows registry editor
  7. Click OK to close the multi-string value text box.
  8. Exit the Registry Editor and restart Windows.
Service host group name is mentioned as an additional switch/parameter for svchost.exe, and it’s highlighted in [Figure 1] above. The service host group can be any one of the following, depending upon how each service is implemented:

  • LocalService
  • LocalServiceAndNoImpersonation
  • LocalServiceNetworkRestricted
  • LocalServiceNoNetwork
  • LocalServiceNoNetworkFirewall
  • LocalServicePeerNet
  • LocalSystemNetworkRestricted
  • netsvcs
  • NetworkService
  • NetworkServiceAndNoImpersonation
  • NetworkServiceNetworkRestricted

The above steps should resolve error 1083 and 1053 when starting a Windows service.


One small request: If you liked this post, please share this?

One "tiny" share from you would seriously help a lot with the growth of this blog. Some great suggestions:
  • Pin it!
  • Share it to your favorite blog + Facebook, Reddit
  • Tweet it!
So thank you so much for your support. It won't take more than 10 seconds of your time. The share buttons are right below. :)

Related articles

Ramesh Srinivasan is passionate about Microsoft technologies and he has been a consecutive ten-time recipient of the Microsoft Most Valuable Professional award in the Windows Shell/Desktop Experience category, from 2003 to 2012. He loves to troubleshoot and write about Windows. Ramesh founded Winhelponline.com in 2005.

11 thoughts on “Error 1083 “The executable program that this service is configured to run in does not implement the service””

  1. My remote user’s sound card stopped working last week. The audio service failed to start because the multimedia something or other wouldn’t start. When I tried to start the multimedia whatever it was service, I got the 1083 error. I was able to fix my sound using this guide. I very much appreciate your posting this. Thank you.

    Reply
  2. Hey, my BFE service isn’t started by LocalServiceNoNetwork but the name is already in the place you mentioned. I have no malware or anything. What should I do when I find the service shortname already there?

    Reply
  3. Hi,
    had this problem, bfe,ics,firewall, ip sec….none would start. midway thru this fix I noticed GROUP POLICY CLIENT service was not running, turned it on and everything works. I was just in gpedit.msc which worked fine and never said it’s service wasn’t running…u think it would. Also no error reports mentioned this or win. troubleshooting. thanks for pointing me in the right direction!

    Reply
  4. Hello Ramesh, Am having same problem with staring windows service. I dont have host group on my service properties. So what should i add and which one to select in the svcHost any inputs?

    Reply
  5. Well done & thanks.

    After searching for hours to a soulution (Firewall not working, e-mail links not opening, new antivirus wold not load) I followed your solution above and it worked.

    Nortor & Bitdefender support could not workout why their firewalls were blocked.

    Reply

Leave a Reply to Tom Cancel reply