Malwarebytes Real-Time Protection layers turned off at every startup

Malwarebytes Premium is an all-in-one security suite which guards the system from ransomware, exploits, malware and also provides web protection. The current version of Malwarebytes, v3.0.5, has an small issue where it shows the message Real-Time Protection layers turned off in the notification area at every startup. This issue is reportedly fixed in v3.0.6 which would be released soon.

Real-Time Protection layers turned off

One or more Real-Time Protection layers are turned off. Turn on all Real-Time Protection layers to block and prevent threats.

The above warning is supposed to appear only when one or more of the following features is turned off:

  • Web Protection
  • Exploit Protection
  • Malware Protection
  • Ransomware Protection

However, the current version of Malwarebytes v3.0.5 displays the warning at every startup although all four protection settings are turned ON.

real-time protection layers

Real-Time Protection layers turned off





Malwarebytes team is already aware of the problem and they said that the issue will be fixed in v3.0.6.. If you are experiencing any sort of issue at all with an earlier version of Malwarebytes (e.g. 3.0.4 or 3.0.5), please try this newest one instead. Malwarebytes v. 3.0.6.x can be downloaded from this link.

Instructions


Step 1: Clean
- Uninstall Malwarebytes 3.0.5 from the "Windows Control Panel":https://www.bleepingcomputer.com/tutorials/uninstall-a-program-in-windows/.
- Reboot your computer.
- Note: If you are running or have been advised advised to revert to version 2.2.1,  please download and run the MBAM-clean tool from the link below. This tool will remove any remnants of earlier versions of Malwarebytes prior to version 3.0.
** "MBAM Clean Tool Download":https://downloads.malwarebytes.org/file/mbam_clean
- Reboot your computer


Step 2: Installation
- Download and Run the Malwarebytes 3.0.6 installer from the link below
** "Download MB3 Installer":https://www.malwarebytes.com/mwb-download/thankyou/
- Locate and double click the file, mb3-setup-consumer.exe, to run the installer:
** Be sure to check your downloads folder if you do not see the file
** You may see a notification explaining that your existing Malwarebytes Anti-Malware, Malwarebytes Anti-Exploit, or Malwarebytes Anti-Ransomware (Beta) applications need to be uninstalled before you can install Malwarebytes 3.0.
- Press Accept, then follow this prompts on the installer window.
- Malwarebytes will open automatically to the new welcome screen.
- If you have a premium subscription for either Malwarebytes Anti-Malware or Malwarebytes Anti-Exploit Proceed to Activation.


Step 3: Activation (Premium Subscribers Only)
- If you do not already have your license key on hand, You can obtain your license info here:https://support.malwarebytes.com/customer/portal/articles/1835295-how-do-i-obtain-my-license-key-or-confirmation-email-?b_id=6400
- Press the Activate button in the top right.
** If you only see a My Account button in the top right your license has already migrated over. Please click My Account to verify.
- Copy and Paste your License info to the appropriate boxes.
** If your activation info has an ID press the "My license came with a License ID" _link_
- Click the Activate button to activate your Malwarebytes 3.0 Premium license
- Restart your PC one more time.

Src: Malwarebytes Forums

Information in this post applies if you have Malwarebytes 3.0.x Premium version, either running a licensed copy or using its 14-day trial. Free version of Malwarebytes doesn’t have Web, Exploit and Ransomware protection features.

About the author

Ramesh Srinivasan founded Winhelponline.com back in 2005. He is passionate about Microsoft technologies and has a vast experience in the ITeS industry — delivering support for Microsoft's consumer products. He has been a Microsoft MVP [2003 to 2012] who contributes to various Windows support forums.

48 thoughts on “Malwarebytes Real-Time Protection layers turned off at every startup

  1. MB version 3.1.2.1733
    windows 10
    Have the same problem, exploit protection is off and cant be activated.

  2. Malwarebytes premium, version 3.1.2.1733 :
    on the protection tab
    under Real-Time Protection heading
    switch: Malware Protection: Prevents malware infections
    symptom: it’s turned off.
    action: when i turn it back on, it turns itself back off a second later.

    what to do?

  3. Same problem with 3.1.2.1733 on Windows 10, 1703 (Creators). Web protection just says “starting …” then turns “off”.

  4. Have a new desktop with windows 10 and premium Malawarebytes 3.06 and am having the same problems grrrrr

  5. Not fixed in V3.06 as this problem just cropped up for me IN this version. In checking, the protections window, real time IS turned off and this has happened when my system is running and not just at startup.

  6. I fixed mine!! I have the 3.0. I went to scans and chose Hyper scan, it ran (threat scan wouldn’t) and showed all protections on. Then I went back to scans and chose Threat scan this time. It ran, and showed all protections on!! woohoo

  7. 1. Right click the MBAM systray icon.

    2. Select “Quit Malwarebytes.” This will cause the Windows Action Center to red-flag your anti-virus programs.

    3. Click the flag (Action Center) and select “Check Anti-virus programs. This will cause a pop-up to appear listing the status of your anti-virus programs.

    4. Select Malwarebytes.

    5. Click “Turn On.” Wait a few seconds.

    The big MBAM systray pop-up telling you to turn on protection will probably still show up one more time (It did for me), but if you open MBAM BEFORE clicking “Turn On” you should see that all the layers are, in fact, on. So you can simply X out of the pop-up without clicking anything.

    Both these issues (Not starting all protections, and the systray pop-up) are BUGS that I’m sure MBAM will get worked out, but it is annoying and concerning.

    Note: If you don’t turn off your other programs before starting this list, the Action Center won’t flag the problem and you won’t have access to the Windows feature in step #2. However, after you’ve gone through all the steps, and MBAM is fully working, you can turn your other programs back on without it changing MBAM’s status. At least that was the case with MS Security Essentials. If you’re running something else you’ll have to see for yourself how it affects MBAM

  8. Running Windows 10. Malwarebytes Premium version 3.0.6.1469. Web protection will not activate. Tried rebooting. Tried turning off VPN. Problem started this morning.

  9. Perfect! Just in time for the massive wannacry ransomware threat – MBAM stops working, as everyone has said here. On 5/17/16 MBAM just allowed cerber ransomware to sail on in and encrypt and infect my entire PC. I will NEVER buy this POS product again. I just emailed these morons that I am DONE. You have to email these jerks just to turn off auto renew. That is BS!

  10. Same issue:
    Windows 10 Pro
    MBytes: 3.0.6.1469
    Component package version: 1.0.1974
    Update package version: 1.0.1974

    Behavior: Web Protection won’t turn on. Hangs @ starting and then resets to off

  11. I have the same problem and I did everything to try and fix it without any success. I even reinstalled to the newer version and did a hard reboot without any luck. I guess I won’t be renewing my Malwarebytes Premium since I don’t even know if it is working.

  12. I have the trial 3.1.2 and it was fine up until the other day it just stopped and now I can’t get it to come back on and it’s now stuck forever at “starting”.

  13. Have version 3.0.6.1469 on two computers (Win10 – one 32-bit and one 64-bit) with same issue intermittently on both machines. Normally it’s the Web Protection layers that is indicated as being off. A system reboot will sometimes “fix” the problem temporarily.

    I have totally removed Malwarebytes and reinstalled from scratch as recommended on the company’s website, but that does not fix the problem.

    I have stopped recommending Malwarebytes to my computer customers and certainly will not be installing it for any of them until this aggravating problem is resolved.

  14. A simple reboot fixed the problem for me. I get that handling all the variables on countless machines isn’t easy and that testing will only uncover so much. Thank you for all your hard work to make this a better product!

  15. MalwareBytes Premium v3.06 still causing the same problem for me too. Multiple reinstalls have not helped. Will MalwwareBytes post some newer update or solution here, please?

  16. V3.0.6.1469 on two Windows 10 computers, one 64 bit and on older 32 bit machine – same issues as described by other users. Mostly it’s Web Protection that shows as not started on mine, but sometimes other protection services. Reboot sometimes fixes it temporarily – annoying.

  17. For me, its “exploit protection” that’s always turned off on bootup. Mine easily turns on but it’s suspicious for it to bootup with it turned off. Seems to me that’s when you really need it.

  18. On 4/01/2017, I installed Malwarebytes 3.0.6.1469 on Windows XP, Windows 7, and Windows 10 systems.
    1) Malwarebytes 3.0.6.1469 doesn’t give choice of installing “premium trial”. It always installs it.
    2) With Windows XP:
    a) It hangs “scanning root kits”.
    b) It declares HKLM\SOFTWARE\MICROSOFT\SECURITYCENTER\UPDATESDISABLENOTIFY a PUM
    (Possibly Unwanted Modification)!
    c) It slows LAN traffic (between XP and W10) to take over an hour for a 30-second operation!
    3) With Windows 7:
    -MB3 won’t update definitions
    -crashes on start-up
    -prevents re-installation of mbam-setup-2.2.1.1043.exe.
    -Mbam-clean-2.3.0.1001.exe doesn’t remove any mbam files!
    4) With Windows 10:
    -no problems so far
    Malewarebytes has ruined a previously good product. I’ve gone back to using 2.2.1.

  19. Same issue with v3.0.6 ever since it has installed. Had no issues with earlier version 2.xx. Some times I can exit MB, then restart and it’s fine for several days. Some times I go into MB and restore to default settings under Application and Protection tabs then works fine for several days. I’m lucky, it’s not a daily issue with my several Windows 7 & 10 computers, maybe two or three times a week. Hope they fix it soon. 4/2/17

  20. Same problem here. This notification is really bothersome and won’t easily go away. It just randomly appears after starting and won’t go away until the button is pressed. Is a pest and unwanted.

  21. Same problem here. Version 3.0.6.1469.

    I keep getting warned that real time web protection is turned off. Sometimes re-booting fixes it. More recently it doesn’t. I try to turn on real time web protection …. nothing happens.

  22. Same problem with version 3.0.6.1469 package version 1.0.75 update version 1.0.1596. I recommend cancel auto renew and start searching for malware protection that works.

  23. It appears the MBAM service may be the problem. At the moment it shows as “stopping”, but I cannot restart malwarebytes without a reboot, which would be a lot of trouble at this moment.

    US made software is crap!

  24. I have the same issue with 3.0.6 on a few of my computers as well. One, which is a laptop running Windows 10, can’t even run the latest version without giving a BSOD. I REALLY miss version 2.xx of Malwarebytes — never had ANY issues there! I am a Premium member also, and wish they would actually fix their **** program!

  25. I have the same issue ever since installing 3.06 – have used this program for years with no issues – latest download and now everytime I start our computer I get the error message as well about real time layers turned off and it won’t let me do anything even though they are all turned on – hangs the computer. What other programs out there are folks using as I have paid for the premium version and this is a big pain to deal with every time we start our computer and we are using this as our business so don’t want to deal with this every day!

  26. I too am having the same issue. My Real Protection won’t enable. When I turn it on, it says Starting….and that is as far as it goes. It will not turn on. I have version 3.0.6.1469. Why did I pay for this if it doesn’t work properly!

  27. I have version 3.0.6.1469 and it still says ‘Exploit Protection: Prevents vulnerability exploits and zero-day attacks’ is off. When I click to start it just hangs on ‘Starting…’ until it stops trying and it stays off.

  28. 3/13/17 Current Version 3.0.6.1469 on Windows 7 Ultimate: The “Real-Time Protection Layers turned off” message is becoming a real PIA. It seems to come every hour or so. Obviously V3.0.6.1469 has not solved the problem.

  29. This is ridiculous. I have the same issue and never had one before downloading the 3.0.6. Malwarebytes needs to get this fixed.

  30. February 25, 2017
    I have 3.0.6 I get the error box Real-Time Protection layers turned off with every startup and I can’t find a way to turn them on. I have a feeling I running with no web protection. I am not PC savvy and to me, support.Malwarebytes.com is not helpful. I’m very unhappy with Malware.

  31. V3.0.6.1469
    Windows 7 Premium
    Scan shows I am protected but receive warning real-time protection layers turned off. Go to settings to turn on. Shows “starting” but never starts.

  32. Having the same issue here. Suddenly I’m continuously being told that my real time protection is turned off, I click to turn it on, it says “starting”, and then just turns it off again. And yes, I am using version 3.0.6.1469 as well.

  33. The problem with “Ransomware Protection…” remains with 3.0.6.1469.
    If one turns it on you get a “Installing…” (or is it “Initializaing…?) message, which never seems to go away. How long does the installation take?

    I used to have the same problem with “Web Protection. But, I uninstalled the earlier 3.0.6… version, purged the Registry of all “MalwareBytes” entries, shut down, started up, and downloaded the 3.0.6.1469 version from the MalwareBytes web site. The “Ransomware Protection…” remains.

  34. Add me to your list – V3.0.6 has the same real time protection problem. Windows 7 Pro x64. I feel like MBAM is using me as a beta tester.

  35. I didn’t have this problem in 3.0.5 but I have it in 3.0.6 If I start the Web Protection in Settings it says starting then it stops and then the message pops up again and again and again. I have this on 2 of my three machines

  36. Exactly the same problem here.
    V3.0.6.1469 Keeps turning off Real-Time Protection so it’s still an issue.
    Win 7, 64 up to date.

  37. V3.0.6 seems to have caused the problem for me. Everything was working until today and now I get this real time protection turned off bubble. That’s really useful as my pc is now unprotected by its own anti malware program.

Leave a Comment